Back to overview
Downtime

API unavailable as a result of AWS network outage

Oct 20 at 09:04am PDT
Affected services
Arraylake API (api.earthmover.io)
Arraylake Web Application (app.earthmover.io)

Resolved
Oct 20 at 03:02pm PDT

Latency and request performance have returned to normal levels, and the Earthmover platform is operating as expected again. That said, given the earlier instability in AWS us-east-1, we’re continuing to keep a close watch on system health and AWS service status.

Updated
Oct 20 at 02:28pm PDT

The Earthmover platform is reachable again, but performance is highly degraded. Latency is significantly elevated and requests are still intermittently failing due to ongoing instability in AWS us-east-1. We’re continuing to monitor and will provide updates as things stabilize.

Updated
Oct 20 at 12:18pm PDT

The AWS us-east-1 outage continues to impact the Earthmover platform with no meaningful recovery observed so far. Our team is actively monitoring system health, evaluating possible mitigation options, and tracking AWS recovery efforts. We’ll share updates as soon as there are material changes.

Updated
Oct 20 at 10:00am PDT

AWS is reporting signs of recovery in us-east-1, but we have not yet observed any improvement in Earthmover systems. Service disruption remains ongoing. We’ll continue monitoring and share updates as conditions change.

Updated
Oct 20 at 09:35am PDT

The AWS us-east-1 outage has worsened and is now causing a full disruption of the Earthmover platform. Most requests are failing or timing out. We’re monitoring closely and will update as soon as services begin to recover.

Created
Oct 20 at 09:04am PDT

We are tracking a significant outage in AWS us-east-1. This is currently impacting network traffic to the Earthmover API. More details will be posted as we investigate the issue.