Back to overview
Degraded

ValueError: V1 repositories can no longer be opened in the Arraylake client.

Oct 02 at 01:45pm PDT
Affected services
Arraylake API (api.earthmover.io)
Arraylake Web Application (app.earthmover.io)

Resolved
Oct 02 at 02:30pm PDT

We have rolled out a fix to the issue. All systems have now returned to regular service.

Created
Oct 02 at 01:45pm PDT

On Oct. 2 we experienced an issue which prevented customers from accessing repos between 4:45pm and 5:30pm EST. The issue originated with a service release which was not backwards compatible with existing client versions. The error you may have seen would have been ValueError: V1 repositories can no longer be opened in the Arraylake client. No data were lost, and the issue has been resolved.

Further, this downtime was not reflected in https://status.earthmover.io/ which monitors the availability of our API but not this particular functionality.

In response to this incident, we are reviewing our integration testing to understand why this issue wasn’t detected before the release. We are also augmenting our status monitoring to include deeper verification of functionality. Next week we will share a technical post mortem with deeper analysis of the root cause of the incident.

We apologize sincerely for this incident, and we thank you for your continued feedback and support.